re = /url\(\\[\'|\"]((?!data:|\/).*)\\[\'|\"]\)/m
str = 'url(\\\'font-awesome.woff\\\') url(\\\'bont-awesome.woff\\\') url(\\\'/favicon.ico\\\') url(\\\'data:whatever\\\')'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end