import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "url\\(\\\\[\\'|\\\"]((?!data:|\\/).*)\\\\[\\'|\\\"]\\)";
final String string = "url(\\'font-awesome.woff\\') url(\\'bont-awesome.woff\\') url(\\'/favicon.ico\\') url(\\'data:whatever\\')";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.UNICODE_CHARACTER_CLASS | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}