import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:([[:xdigit:]]{2})([^[:xdigit:]]?)(?1)(\\2(?1))(?3){3}|((?1){2})((?2))(?4)\\5(?4))$";
final String string = "# Common formats :\n"
+ "fc:92:3b:ed:cb:a9\n"
+ "fc-92-3b-ed-cb-a9\n"
+ "fc92.3bed.cba9\n\n"
+ "# Matching is case insensitive :\n"
+ "fC:92:3b:Ed:cB:a9\n"
+ "fC92.3bEd.cBa9\n\n"
+ "# Separator can be empty or any character execept hexadecimal ones :\n"
+ "fc 92 3b ed cb a9\n"
+ "fc92g3bedgcba9\n"
+ "fc923bedcba9\n\n"
+ "# Separators must be identicals, will not match otherwise :\n"
+ "fc:92:3b-ed:cb:a9\n"
+ "fc92.3bed;cba9";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}