import re
regex = re.compile(r"^(?:([[:xdigit:]]{2})([^[:xdigit:]]?)(?1)(\2(?1))(?3){3}|((?1){2})((?2))(?4)\5(?4))$", flags=re.MULTILINE)
test_str = ("# Common formats :\n"
"fc:92:3b:ed:cb:a9\n"
"fc-92-3b-ed-cb-a9\n"
"fc92.3bed.cba9\n\n"
"# Matching is case insensitive :\n"
"fC:92:3b:Ed:cB:a9\n"
"fC92.3bEd.cBa9\n\n"
"# Separator can be empty or any character execept hexadecimal ones :\n"
"fc 92 3b ed cb a9\n"
"fc92g3bedgcba9\n"
"fc923bedcba9\n\n"
"# Separators must be identicals, will not match otherwise :\n"
"fc:92:3b-ed:cb:a9\n"
"fc92.3bed;cba9")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")