const regex = /^(?:([[:xdigit:]]{2})([^[:xdigit:]]?)(?1)(\2(?1))(?3){3}|((?1){2})((?2))(?4)\5(?4))$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:([[:xdigit:]]{2})([^[:xdigit:]]?)(?1)(\\2(?1))(?3){3}|((?1){2})((?2))(?4)\\5(?4))$', 'gm')
const str = `# Common formats :
fc:92:3b:ed:cb:a9
fc-92-3b-ed-cb-a9
fc92.3bed.cba9
# Matching is case insensitive :
fC:92:3b:Ed:cB:a9
fC92.3bEd.cBa9
# Separator can be empty or any character execept hexadecimal ones :
fc 92 3b ed cb a9
fc92g3bedgcba9
fc923bedcba9
# Separators must be identicals, will not match otherwise :
fc:92:3b-ed:cb:a9
fc92.3bed;cba9`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}