#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(Micron_5300)?(_|HC_)?MTFDDA[KV](240|480|960|1T9|3T8|7T6)TD[ST]$"
Local $sString = "Micron_5300_MTFDDAK1T9TDS" & @CRLF & _
"Micron_5300HC_MTFDDAK960TDS" & @CRLF & _
"MTFDDAK1T9TDT" & @CRLF & _
"HC_MTFDDAK960TDS" & @CRLF & _
"_MTFDDAK960TDS" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")