re = /^(Micron_5300)?(_|HC_)?MTFDDA[KV](240|480|960|1T9|3T8|7T6)TD[ST]$/m
str = 'Micron_5300_MTFDDAK1T9TDS
Micron_5300HC_MTFDDAK960TDS
MTFDDAK1T9TDT
HC_MTFDDAK960TDS
_MTFDDAK960TDS
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end