using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(Micron_5300)?(_|HC_)?MTFDDA[KV](240|480|960|1T9|3T8|7T6)TD[ST]$";
string input = @"Micron_5300_MTFDDAK1T9TDS
Micron_5300HC_MTFDDAK960TDS
MTFDDAK1T9TDT
HC_MTFDDAK960TDS
_MTFDDAK960TDS
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}