package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(Micron_5300)?(_|HC_)?MTFDDA[KV](240|480|960|1T9|3T8|7T6)TD[ST]$`)
var str = `Micron_5300_MTFDDAK1T9TDS
Micron_5300HC_MTFDDAK960TDS
MTFDDAK1T9TDT
HC_MTFDDAK960TDS
_MTFDDAK960TDS
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}