using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"_\d{2}\.csv$";
string input = @"gfrt_32_20.csv
wertf_18.csv
12_01.csv
ith_Raw.csv";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}