$re = '/_\d{2}\.csv$/m';
$str = 'gfrt_32_20.csv
wertf_18.csv
12_01.csv
ith_Raw.csv';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);