import re
regex = re.compile(r"_\d{2}\.csv$", flags=re.MULTILINE)
test_str = ("gfrt_32_20.csv\n"
"wertf_18.csv\n"
"12_01.csv\n\n"
"ith_Raw.csv")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")