using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b[^_\n]+_flavor_id:\s*(\d+)";
string input = @"server:
tenant: ""admin""
availability_zone: ""nova""
cpu_overcommit_ratio: 1:1
memory_overcommit_ratio: 1:1
xyz_flavor_id: 1
abc_flavor_id: 2
I am able to figure the regex to ma";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}