import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b[^_\\n]+_flavor_id:\\s*(\\d+)";
final String string = "server:\n"
+ " tenant: \"admin\"\n"
+ " availability_zone: \"nova\"\n"
+ " cpu_overcommit_ratio: 1:1\n"
+ " memory_overcommit_ratio: 1:1\n"
+ " xyz_flavor_id: 1\n"
+ " abc_flavor_id: 2\n"
+ "I am able to figure the regex to ma";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}