$re = '/\b[^_\n]+_flavor_id:\s*(\d+)/';
$str = 'server:
tenant: "admin"
availability_zone: "nova"
cpu_overcommit_ratio: 1:1
memory_overcommit_ratio: 1:1
xyz_flavor_id: 1
abc_flavor_id: 2
I am able to figure the regex to ma';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);