// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\b[^_\n]+_flavor_id:\s*(\d+)").unwrap();
let string = "server:
tenant: \"admin\"
availability_zone: \"nova\"
cpu_overcommit_ratio: 1:1
memory_overcommit_ratio: 1:1
xyz_flavor_id: 1
abc_flavor_id: 2
I am able to figure the regex to ma";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}