#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(.{2})(.{3})"
Local $sString = "2346" & @CRLF & _
"UNDEF"
Local $sSubst = "$1.$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)