$re = '/(.{2})(.{3})/';
$str = '2346
UNDEF';
$subst = "$1.$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;