package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(.{2})(.{3})`)
var str = `2346
UNDEF`
var substitution = "$1.$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}