import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\A(?:\\s*^(?:#\\w+.*\\s*|extern\\s+.+)$)*+(?<namespace>\\s*namespace(?:\\s+utTestNamespace\\s*(?>(?<block>\\{(?:[^\\{\\}]*(?&block)*)*\\}))|(\\s*[\\w:]*\\s*\\{)(?&namespace)\\s*\\}))\\s*\\z";
final String string = "#include <memory>\n"
+ "#include <vector>\n"
+ "#include <gtest/gtest.h>\n\n"
+ "namespace utTestNamespace\n"
+ "{\n"
+ "using ::testing::NiceMock;\n"
+ "# some code here\n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}