re = /\A(?:\s*^(?:#\w+.*\s*|extern\s+.+)$)*+(?<namespace>\s*namespace(?:\s+utTestNamespace\s*(?>(?<block>{(?:[^{}]*(?&block)*)*}))|(\s*[\w:]*\s*{)(?&namespace)\s*}))\s*\z/m
str = '#include <memory>
#include <vector>
#include <gtest/gtest.h>
namespace utTestNamespace
{
using ::testing::NiceMock;
# some code here
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end