import re
regex = re.compile(r"\A(?:\s*^(?:#\w+.*\s*|extern\s+.+)$)*+(?<namespace>\s*namespace(?:\s+utTestNamespace\s*(?>(?<block>{(?:[^{}]*(?&block)*)*}))|(\s*[\w:]*\s*{)(?&namespace)\s*}))\s*\z", flags=re.MULTILINE)
test_str = ("#include <memory>\n"
"#include <vector>\n"
"#include <gtest/gtest.h>\n\n"
"namespace utTestNamespace\n"
"{\n"
"using ::testing::NiceMock;\n"
"# some code here\n"
"}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")