const regex = /\A(?:\s*^(?:#\w+.*\s*|extern\s+.+)$)*+(?<namespace>\s*namespace(?:\s+utTestNamespace\s*(?>(?<block>{(?:[^{}]*(?&block)*)*}))|(\s*[\w:]*\s*{)(?&namespace)\s*}))\s*\z/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\A(?:\\s*^(?:#\\w+.*\\s*|extern\\s+.+)$)*+(?<namespace>\\s*namespace(?:\\s+utTestNamespace\\s*(?>(?<block>{(?:[^{}]*(?&block)*)*}))|(\\s*[\\w:]*\\s*{)(?&namespace)\\s*}))\\s*\\z', 'gm')
const str = `#include <memory>
#include <vector>
#include <gtest/gtest.h>
namespace utTestNamespace
{
using ::testing::NiceMock;
# some code here
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}