# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((?:(?<!\d)(\d{1,4}(?:[\.,]\d{1,6})?)\s+((?:kilogram|kilos|kg)))|(?:((?:kilogram|kilos|kg))\s+(\d{1,4}(?:[\.,]\d{1,6})?)))/*THIS IS THE NUMBER: '$2$5'* AND *THIS IS THE UNIT: '$3$4'*/mg;t' <<< "toitnt kg 15.6 oeingoiegn
oinef 45.9009090909 kg eoif
something blah 65.78 kilos ow"