#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)((?:(?<!\d)(\d{1,4}(?:[\.,]\d{1,6})?)\s+((?:kilogram|kilos|kg)))|(?:((?:kilogram|kilos|kg))\s+(\d{1,4}(?:[\.,]\d{1,6})?)))"
Local $sString = "toitnt kg 15.6 oeingoiegn" & @CRLF & _
"oinef 45.9009090909 kg eoif" & @CRLF & _
"something blah 65.78 kilos ow"
Local $sSubst = "*THIS IS THE NUMBER: '$2$5'* AND *THIS IS THE UNIT: '$3$4'*"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)