# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((?:(?<!\d)(\d{1,4}(?:[\.,]\d{1,6})?)\s+((?:kilogram|kilos|kg)))|(?:((?:kilogram|kilos|kg))\s+(\d{1,4}(?:[\.,]\d{1,6})?)))"
test_str = ("toitnt kg 15.6 oeingoiegn\n"
"oinef 45.9009090909 kg eoif\n"
"something blah 65.78 kilos ow")
subst = "*THIS IS THE NUMBER: '$2$5'* AND *THIS IS THE UNIT: '$3$4'*"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.