import Foundation
let pattern = #"((?:(?<!\d)(\d{1,4}(?:[\.,]\d{1,6})?)\s+((?:kilogram|kilos|kg)))|(?:((?:kilogram|kilos|kg))\s+(\d{1,4}(?:[\.,]\d{1,6})?)))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
toitnt kg 15.6 oeingoiegn
oinef 45.9009090909 kg eoif
something blah 65.78 kilos ow
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"*THIS IS THE NUMBER: '$2$5'* AND *THIS IS THE UNIT: '$3$4'*"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)