#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\d+(?=\D*$)"
Local $sString = "http://forums.scamadviser.com/site-feedback-issues-feature-requests/20/" & @CRLF & _
"https://forums.questionablecontent.net/index.php/board,1.50.html" & @CRLF & _
"https://forums.comodo.com/how-can-i-help-comodo-please-we-need-you-b39.30/"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)