const regex = /\d+(?=\D*$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d+(?=\\D*$)', 'gm')
const str = `http://forums.scamadviser.com/site-feedback-issues-feature-requests/20/
https://forums.questionablecontent.net/index.php/board,1.50.html
https://forums.comodo.com/how-can-i-help-comodo-please-we-need-you-b39.30/`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);