import Foundation
let pattern = #"\d+(?=\D*$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
http://forums.scamadviser.com/site-feedback-issues-feature-requests/20/
https://forums.questionablecontent.net/index.php/board,1.50.html
https://forums.comodo.com/how-can-i-help-comodo-please-we-need-you-b39.30/
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)