#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mu)^(?!^[\p{Z}]|.*[\p{Z}]$).*$"
Local $sString = " x" & @CRLF & _
                "x " & @CRLF & _
                "xx" & @CRLF & _
                " xx" & @CRLF & _
                " char \u2000 at start" & @CRLF & _
                "char \u2000 at end " & @CRLF & _
                "in middle char \u2000"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
    _ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")