using System;
using System.Text.RegularExpressions;
public class Example
{
    public static void Main()
    {
        string pattern = @"^(?!^[\p{Z}]|.*[\p{Z}]$).*$";
        string input = @" x
x 
xx
 xx
 char \u2000 at start
char \u2000 at end 
in middle char \u2000";
        RegexOptions options = RegexOptions.Multiline | RegexOptions.CultureInvariant;
        
        foreach (Match m in Regex.Matches(input, pattern, options))
        {
            Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
        }
    }
}