const regex = /^(?!^[\p{Z}]|.*[\p{Z}]$).*$/gmu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!^[\\p{Z}]|.*[\\p{Z}]$).*$', 'gmu')
const str = ` x
x
xx
xx
char \\u2000 at start
char \\u2000 at end
in middle char \\u2000`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}