#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?|([a-zA-Z0-9]+)\(([a-zA-Z\s]+)\)|\(([a-zA-Z\s]+)\)([a-zA-Z0-9]+))|(\b[\(|\{|\[|\«]+[\w\s]*[\)|\}|\]|\»]+)"
Local $sString = "(Weather) is good. // not need to mark this beacuase this word correct word" & @CRLF & _
"Weath(er) is good. // mark" & @CRLF & _
"Weath(er is good). // mark" & @CRLF & _
"Weather (is) (good)." & @CRLF & _
"My name is Rah(eel) // mark" & @CRLF & _
"Best pro(duct) // mark" & @CRLF & _
"(Weather is good) // not need to mark this beacuase this word konown word" & @CRLF & _
"we(ather)" & @CRLF & _
"(weath)er is good. // mark" & @CRLF & _
"(weath)er // mark" & @CRLF & _
"weather(is fine)" & @CRLF & _
"weather is good" & @CRLF & _
"{weather is good} //not need to mark correct" & @CRLF & _
"weat{er is good} // mark" & @CRLF & _
"we{ather} is fine // mark" & @CRLF & _
"" & @CRLF & _
"{weathe}r is fine // i want to mark this word" & @CRLF & _
"{weather is fin}e // i want to mark this word" & @CRLF & _
"" & @CRLF & _
"[weather is good] //not need to mark correct" & @CRLF & _
"weat[her is good] // mark" & @CRLF & _
"we[ather] is fine // mark" & @CRLF & _
"" & @CRLF & _
"[weathe]r is fine // i want to mark this word" & @CRLF & _
"[weather is f]ine // i want to mark this word" & @CRLF & _
"" & @CRLF & _
"we[ather] is fine // mark" & @CRLF & _
"" & @CRLF & _
"«weather is good» //not need to mark" & @CRLF & _
"weat«her is good» // mark" & @CRLF & _
"" & @CRLF & _
"we«ather» is fine // mark" & @CRLF & _
"" & @CRLF & _
"«weat»her is fine // i want to mark this word" & @CRLF & _
"«weather is fi»ne // i want to mark this word" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")