import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?|([a-zA-Z0-9]+)\\(([a-zA-Z\\s]+)\\)|\\(([a-zA-Z\\s]+)\\)([a-zA-Z0-9]+))|(\\b[\\(|\\{|\\[|\\«]+[\\w\\s]*[\\)|\\}|\\]|\\»]+)";
final String string = "(Weather) is good. // not need to mark this beacuase this word correct word\n"
+ "Weath(er) is good. // mark\n"
+ "Weath(er is good). // mark\n"
+ "Weather (is) (good).\n"
+ "My name is Rah(eel) // mark\n"
+ "Best pro(duct) // mark\n"
+ "(Weather is good) // not need to mark this beacuase this word konown word\n"
+ "we(ather)\n"
+ "(weath)er is good. // mark\n"
+ "(weath)er // mark\n"
+ "weather(is fine)\n"
+ "weather is good\n"
+ "{weather is good} //not need to mark correct\n"
+ "weat{er is good} // mark\n"
+ "we{ather} is fine // mark\n\n"
+ "{weathe}r is fine // i want to mark this word\n"
+ "{weather is fin}e // i want to mark this word\n\n"
+ "[weather is good] //not need to mark correct\n"
+ "weat[her is good] // mark\n"
+ "we[ather] is fine // mark\n\n"
+ "[weathe]r is fine // i want to mark this word\n"
+ "[weather is f]ine // i want to mark this word\n\n"
+ "we[ather] is fine // mark\n\n"
+ "«weather is good» //not need to mark\n"
+ "weat«her is good» // mark\n\n"
+ "we«ather» is fine // mark\n\n"
+ "«weat»her is fine // i want to mark this word\n"
+ "«weather is fi»ne // i want to mark this word\n\n\n\n\n\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}