// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?|([a-zA-Z0-9]+)\(([a-zA-Z\s]+)\)|\(([a-zA-Z\s]+)\)([a-zA-Z0-9]+))|(\b[\(|\{|\[|\«]+[\w\s]*[\)|\}|\]|\»]+)").unwrap();
let string = "(Weather) is good. // not need to mark this beacuase this word correct word
Weath(er) is good. // mark
Weath(er is good). // mark
Weather (is) (good).
My name is Rah(eel) // mark
Best pro(duct) // mark
(Weather is good) // not need to mark this beacuase this word konown word
we(ather)
(weath)er is good. // mark
(weath)er // mark
weather(is fine)
weather is good
{weather is good} //not need to mark correct
weat{er is good} // mark
we{ather} is fine // mark
{weathe}r is fine // i want to mark this word
{weather is fin}e // i want to mark this word
[weather is good] //not need to mark correct
weat[her is good] // mark
we[ather] is fine // mark
[weathe]r is fine // i want to mark this word
[weather is f]ine // i want to mark this word
we[ather] is fine // mark
«weather is good» //not need to mark
weat«her is good» // mark
we«ather» is fine // mark
«weat»her is fine // i want to mark this word
«weather is fi»ne // i want to mark this word
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}