import Foundation
let pattern = #"(?|([a-zA-Z0-9]+)\(([a-zA-Z\s]+)\)|\(([a-zA-Z\s]+)\)([a-zA-Z0-9]+))|(\b[\(|\{|\[|\«]+[\w\s]*[\)|\}|\]|\»]+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
(Weather) is good. // not need to mark this beacuase this word correct word
Weath(er) is good. // mark
Weath(er is good). // mark
Weather (is) (good).
My name is Rah(eel) // mark
Best pro(duct) // mark
(Weather is good) // not need to mark this beacuase this word konown word
we(ather)
(weath)er is good. // mark
(weath)er // mark
weather(is fine)
weather is good
{weather is good} //not need to mark correct
weat{er is good} // mark
we{ather} is fine // mark
{weathe}r is fine // i want to mark this word
{weather is fin}e // i want to mark this word
[weather is good] //not need to mark correct
weat[her is good] // mark
we[ather] is fine // mark
[weathe]r is fine // i want to mark this word
[weather is f]ine // i want to mark this word
we[ather] is fine // mark
«weather is good» //not need to mark
weat«her is good» // mark
we«ather» is fine // mark
«weat»her is fine // i want to mark this word
«weather is fi»ne // i want to mark this word
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)