using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^,\W\*][^,\*]*[^,\W\*]";
string input = @"term1, term2* ,term3*,term4 , *term5, *term 6 , term 7*,*term 8";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}