$re = '/[^,\W\*][^,\*]*[^,\W\*]/';
$str = 'term1, term2* ,term3*,term4 , *term5, *term 6 , term 7*,*term 8';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);