re = /[^,\W\*][^,\*]*[^,\W\*]/
str = 'term1, term2* ,term3*,term4 , *term5, *term 6 , term 7*,*term 8'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end