// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[^,\W\*][^,\*]*[^,\W\*]").unwrap();
let string = "term1, term2* ,term3*,term4 , *term5, *term 6 , term 7*,*term 8";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}