const regex = /(?m)http(?:s?):\/\/.*?([^\.\/]+?\.[^\.]+?(?:\.\w{2})?)(?:\/|$)/gu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?m)http(?:s?):\\\/\\\/.*?([^\\.\\\/]+?\\.[^\\.]+?(?:\\.\\w{2})?)(?:\\\/|$)', 'gu')
const str = `http://careers.walmart.com/?codes=Linkedin&utm_source=Linkedin&utm_campaign=ALL&utm_medium=SocialOrganic&utm_term=AboutUs&utm_content=Branding
http://publix.jobs
https://jobs.gapinc.com/
https://forum.keyboardmaestro.com/t/simple-search-with-regex-question/15733/5
https://www.somedomain.co.uk/
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}