// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?u)(?m)http(?:s?):\/\/.*?([^\.\/]+?\.[^\.]+?(?:\.\w{2})?)(?:\/|$)").unwrap();
let string = "http://careers.walmart.com/?codes=Linkedin&utm_source=Linkedin&utm_campaign=ALL&utm_medium=SocialOrganic&utm_term=AboutUs&utm_content=Branding
http://publix.jobs
https://jobs.gapinc.com/
https://forum.keyboardmaestro.com/t/simple-search-with-regex-question/15733/5
https://www.somedomain.co.uk/
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}