re = /(?m)http(?:s?):\/\/.*?([^\.\/]+?\.[^\.]+?(?:\.\w{2})?)(?:\/|$)/
str = 'http://careers.walmart.com/?codes=Linkedin&utm_source=Linkedin&utm_campaign=ALL&utm_medium=SocialOrganic&utm_term=AboutUs&utm_content=Branding
http://publix.jobs
https://jobs.gapinc.com/
https://forum.keyboardmaestro.com/t/simple-search-with-regex-question/15733/5
https://www.somedomain.co.uk/
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end