# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b(hyd)\W+/HYDRAULIC /gi;t' <<< "HYD. CYLINDER
HYD CYLINDER
HYD.CYLINDER
HYDRAULIC CYLINDER
CYLINDER,HYD.
CYLINDER,HYDRAULIC
CYLINDER,HYD
CYLINDER, HYD.
CYLINDER, HYDRAULIC
CYLINDER,HYD
"