import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(hyd)\\W+";
final String string = "HYD. CYLINDER\n"
+ "HYD CYLINDER\n"
+ "HYD.CYLINDER\n"
+ "HYDRAULIC CYLINDER\n"
+ "CYLINDER,HYD.\n"
+ "CYLINDER,HYDRAULIC\n"
+ "CYLINDER,HYD\n"
+ "CYLINDER, HYD.\n"
+ "CYLINDER, HYDRAULIC\n"
+ "CYLINDER,HYD\n";
final String subst = "HYDRAULIC ";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}