import re
regex = re.compile(r"\b(hyd)\W+", flags=re.IGNORECASE)
test_str = ("HYD. CYLINDER\n"
"HYD CYLINDER\n"
"HYD.CYLINDER\n"
"HYDRAULIC CYLINDER\n"
"CYLINDER,HYD.\n"
"CYLINDER,HYDRAULIC\n"
"CYLINDER,HYD\n"
"CYLINDER, HYD.\n"
"CYLINDER, HYDRAULIC\n"
"CYLINDER,HYD\n")
subst = "HYDRAULIC "
result = regex.sub(subst, test_str)
if result:
print(result)