# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:\G(?!\A)|<img)
(?s:.+?\bsrc=['"])\K
https?:\/\/.+?(?=\/wp-content\/)/http:\/\/someotherdomain.com/gx;t' <<< "<img
src=\"https://www.example.com/de/wp-content/uploads/sites/1/2017/03/image.jpg\"
data-srcset=\"
https://www.example.com/de/wp-content/uploads/sites/1/2017/03/img1.jpg 507w,
https://www.example.com/de/wp-content/uploads/sites/1/2017/03/img2.jpg 780w,
https://www.example.com/de/wp-content/uploads/sites/74/2017/03/img3.jpg 950w\"
data-sizes=\"
(min-width: 80em) calc(0.5 * (100vw - (100vw- 57em))),
(min-width: 48em) calc(0.5 * (100vw - 5em)),
calc(100vw - 1em)\"
alt=\"image\" class=\"lazyload\">
<img
src=\"https://www.example.com/de/wp-content/uploads/sites/1/2017/03/image.jpg\"
data-srcset=\"
https://www.example.com/de/wp-content/uploads/sites/1/2017/03/img1.jpg 507w,
https://www.example.com/de/wp-content/uploads/sites/1/2017/03/img2.jpg 780w,
https://www.example.com/de/wp-content/uploads/sites/74/2017/03/img3.jpg 950w\"
data-sizes=\"
(min-width: 80em) calc(0.5 * (100vw - (100vw- 57em))),
(min-width: 48em) calc(0.5 * (100vw - 5em)),
calc(100vw - 1em)\"
alt=\"image\" class=\"lazyload\">"