# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
(?:\G(?!\A)|<img)
(?s:.+?\bsrc=['"])\K
https?://.+?(?=/wp-content/)
"""
test_str = ("<img \n"
"src=\"https://www.example.com/de/wp-content/uploads/sites/1/2017/03/image.jpg\"\n"
"data-srcset=\"\n"
" https://www.example.com/de/wp-content/uploads/sites/1/2017/03/img1.jpg 507w,\n"
" https://www.example.com/de/wp-content/uploads/sites/1/2017/03/img2.jpg 780w,\n"
" https://www.example.com/de/wp-content/uploads/sites/74/2017/03/img3.jpg 950w\"\n"
"data-sizes=\"\n"
" (min-width: 80em) calc(0.5 * (100vw - (100vw- 57em))),\n"
" (min-width: 48em) calc(0.5 * (100vw - 5em)),\n"
" calc(100vw - 1em)\"\n"
"alt=\"image\" class=\"lazyload\">\n\n"
"<img \n"
"src=\"https://www.example.com/de/wp-content/uploads/sites/1/2017/03/image.jpg\"\n"
"data-srcset=\"\n"
" https://www.example.com/de/wp-content/uploads/sites/1/2017/03/img1.jpg 507w,\n"
" https://www.example.com/de/wp-content/uploads/sites/1/2017/03/img2.jpg 780w,\n"
" https://www.example.com/de/wp-content/uploads/sites/74/2017/03/img3.jpg 950w\"\n"
"data-sizes=\"\n"
" (min-width: 80em) calc(0.5 * (100vw - (100vw- 57em))),\n"
" (min-width: 48em) calc(0.5 * (100vw - 5em)),\n"
" calc(100vw - 1em)\"\n"
"alt=\"image\" class=\"lazyload\">")
subst = "http://someotherdomain.com"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.VERBOSE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.