import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\G(?!\\A)|<img)\n"
+ "(?s:.+?\\bsrc=['\"])\\K\n"
+ "https?://.+?(?=/wp-content/)";
final String string = "<img \n"
+ "src=\"https://www.example.com/de/wp-content/uploads/sites/1/2017/03/image.jpg\"\n"
+ "data-srcset=\"\n"
+ " https://www.example.com/de/wp-content/uploads/sites/1/2017/03/img1.jpg 507w,\n"
+ " https://www.example.com/de/wp-content/uploads/sites/1/2017/03/img2.jpg 780w,\n"
+ " https://www.example.com/de/wp-content/uploads/sites/74/2017/03/img3.jpg 950w\"\n"
+ "data-sizes=\"\n"
+ " (min-width: 80em) calc(0.5 * (100vw - (100vw- 57em))),\n"
+ " (min-width: 48em) calc(0.5 * (100vw - 5em)),\n"
+ " calc(100vw - 1em)\"\n"
+ "alt=\"image\" class=\"lazyload\">\n\n"
+ "<img \n"
+ "src=\"https://www.example.com/de/wp-content/uploads/sites/1/2017/03/image.jpg\"\n"
+ "data-srcset=\"\n"
+ " https://www.example.com/de/wp-content/uploads/sites/1/2017/03/img1.jpg 507w,\n"
+ " https://www.example.com/de/wp-content/uploads/sites/1/2017/03/img2.jpg 780w,\n"
+ " https://www.example.com/de/wp-content/uploads/sites/74/2017/03/img3.jpg 950w\"\n"
+ "data-sizes=\"\n"
+ " (min-width: 80em) calc(0.5 * (100vw - (100vw- 57em))),\n"
+ " (min-width: 48em) calc(0.5 * (100vw - 5em)),\n"
+ " calc(100vw - 1em)\"\n"
+ "alt=\"image\" class=\"lazyload\">";
final String subst = "http://someotherdomain.com";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}